aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitd22f4ca2e3e421615b601002061690a8f97257c0 (patch)
tree8cfee5bd859365868dc3cb5eb9ba91d9713efb79 /meta-python/recipes-devtools/python/python-m2crypto
parent2d7c7956bd3655755e1e800b7b05732f0c1a3786 (diff)
downloadmeta-openembedded-d22f4ca2e3e421615b601002061690a8f97257c0.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
new file mode 100644
index 0000000000..bcbdf24bb5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -0,0 +1,39 @@
+From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 29 Mar 2013 15:17:17 +0100
+Subject: [PATCH] setup.py: link in sysroot, not in host directories
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+
+Upstream-status: Unknown
+---
+ setup.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index e7c49eb..8deaa34 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+ self.openssl = 'c:\\pkg'
+ else:
+ self.libraries = ['ssl', 'crypto']
+- self.openssl = '/usr'
++ self.openssl = os.environ.get( "STAGING_DIR" )
+
+
+ def finalize_options(self):
+@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+
+ build_ext.build_ext.finalize_options(self)
+
+- opensslIncludeDir = os.path.join(self.openssl, 'include')
+- opensslLibraryDir = os.path.join(self.openssl, 'lib')
++ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
++ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
+
+ self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
+ [opensslIncludeDir]]
+--
+1.8.1.4
+