aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-21 10:58:41 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-22 07:28:15 -0700
commit3bef475e7618ab54f5666ccacbdd892b86ce96a0 (patch)
treeb577735920b555477cb7a3db7cf6d48582d958a5 /meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
parent2d9aca131f4885d78a3d5470f2ef9a8b3fb68a19 (diff)
downloadmeta-openembedded-3bef475e7618ab54f5666ccacbdd892b86ce96a0.tar.gz
python3-asttokens: Upgrade 2.0.4 -> 2.0.5
Upgrade to release 2.0.5: - setup.cfg: remove wheel dependency - Handle starred expressions in tests - Make 3.9 support official - pypy2 instead of pypy2.7 - pypy3 instead of pypy3.5 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb b/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
new file mode 100644
index 0000000000..429a56bae6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
@@ -0,0 +1,17 @@
+SUMMARY = "The asttokens module annotates Python abstract syntax trees (ASTs)"
+HOMEPAGE = "https://github.com/gristlabs/asttokens"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "asttokens"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "9a54c114f02c7a9480d56550932546a3f1fe71d8a02f1bc7ccd0ee3ee35cf4d5"
+
+DEPENDS += "\
+ python3-setuptools-scm-native \
+ python3-wheel-native \
+"
+
+BBCLASSEXTEND = "native"