aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 19:31:01 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 23:02:39 -0800
commit190dc15e40a00f6e37e6d0ff3fc162f5d976e65e (patch)
tree9e64607c75bf0686f77f68f8c679da214ad4b332 /meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
parent6c2b3ae7432bddde04965b6eec10931e6e34981e (diff)
downloadmeta-openembedded-190dc15e40a00f6e37e6d0ff3fc162f5d976e65e.tar.gz
python3-async-timeout: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb21
1 files changed, 19 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
index 7e2ffdb05b..22dffe6462 100644
--- a/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
@@ -1,2 +1,19 @@
-inherit setuptools3
-require python-async-timeout.inc
+SUMMARY = "asyncio-compatible timeout context manager"
+DESCRIPTION = "\
+The context manager is useful in cases when you want to apply \
+timeout logic around block of code or in cases when asyncio.wait_for() \
+is not suitable. Also it's much faster than asyncio.wait_for() because \
+timeout doesn't create a new task."
+HOMEPAGE = "https://github.com/aio-libs/async-timeout"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI[md5sum] = "305c4fa529f2485c403d0dbe14390175"
+SRC_URI[sha256sum] = "0c3c816a028d47f659d6ff5c745cb2acf1f966da1fe5c19c77a70282b25f4c5f"
+
+PYPI_PACKAGE = "async-timeout"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"