aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-09-28 02:19:23 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-28 09:15:08 -0700
commita49f8f7732964ee78aaae4b22f576facbea60ebe (patch)
tree0109d2e32fb3b967ee811fcc36e818062dde0295 /meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
parent796b7f6f4c5fc8d047c519b98aedeeb254f6e213 (diff)
downloadmeta-openembedded-a49f8f7732964ee78aaae4b22f576facbea60ebe.tar.gz
python3-humanfriendly: upgrade 9.2 -> 10.0
`Release 10.0`_ (2021-09-17) ---------------------------- **Noteworthy changes:** - Merged pull request `#45`_ to resolve the issue caused by the conditional :pypi:`pyreadline` requirement on Windows not supporting Python 3.9+. - Updated the readme to use Python 3 in the example (reported in issue `#56`_). Also added a mention of the ``humanfriendly --demo`` command. - Removed the ``humanfriendly.compat.unittest`` alias that presumably no-one is using at this point; it had been rendered useless quite a long time ago (requested in issue `#53`_). **Internal changes:** - Merged pull request `#54`_ which migrates the :pypi:`humanfriendly` project from Travis CI to GitHub Actions and from Coveralls.io to Codecov. - Fixed a deprecation warning concerning ``setup.cfg`` and some Sphinx documentation errors. .. _Release 10.0: https://github.com/xolox/python-humanfriendly/compare/9.2...10.0 .. _#45: https://github.com/xolox/python-humanfriendly/pull/45 .. _#53: https://github.com/xolox/python-humanfriendly/issues/53 .. _#54: https://github.com/xolox/python-humanfriendly/pull/54 .. _#56: https://github.com/xolox/python-humanfriendly/issues/56 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb b/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
new file mode 100644
index 0000000000..b1ece1ac0f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Human friendly output for text interfaces using Python"
+HOMEPAGE = "https://humanfriendly.readthedocs.io/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5d178009f806c2bdd498a19be0013a7a"
+
+PYPI_PACKAGE = "humanfriendly"
+
+SRC_URI[sha256sum] = "6b0b831ce8f15f7300721aa49829fc4e83921a9a301cc7f606be6686a2288ddc"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN}:class-target += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native"