aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-08 15:14:07 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:43:54 -0700
commit5973e833085d978629515ca8488cc96a5245125c (patch)
treeea3da2cc7d346155fc24c9f75d64cab65666105e /meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb
parent5f3eb7cd6dc293a8ebecfcda36fdaa19f8097f91 (diff)
downloadmeta-openembedded-5973e833085d978629515ca8488cc96a5245125c.tar.gz
python3-humanfriendly: Upgrade 4.18 -> 8.2
Upgrade to release 8.2. Consolidate inc and bb files into a single bb file. The year in file LICENCE has been recently updated therefore the checksum has been changed but it still remains a MIT License. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb b/meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb
new file mode 100644
index 0000000000..61c969d760
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanfriendly_8.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Human friendly output for text interfaces using Python"
+HOMEPAGE = "https://humanfriendly.readthedocs.io/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=764e737b117a38d773609885e8d04f0b"
+
+PYPI_PACKAGE = "humanfriendly"
+
+SRC_URI[md5sum] = "e6064a6fe099c4231c3e969ca5fea335"
+SRC_URI[sha256sum] = "bf52ec91244819c780341a3438d5d7b09f431d3f113a475147ac9b7b167a3d12"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native"