aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-icu
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-07-09 21:01:07 -0700
committerKhem Raj <raj.khem@gmail.com>2020-07-12 19:04:17 -0700
commit74c3fc3084c7adce390fe7ca33651ea5949319f8 (patch)
tree22a2cbecd09ad4135a9d86a4d5dc112db980e9ab /meta-python/recipes-devtools/python/python3-icu
parent48509aec24e819237926cfbc29ccdb1b8ca311ee (diff)
downloadmeta-openembedded-74c3fc3084c7adce390fe7ca33651ea5949319f8.tar.gz
python3-icu: add new package
needed by python3-natsort Signed-off-by: Armin Kuster <akuster808@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-icu')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
new file mode 100644
index 0000000000..1b6e890436
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
@@ -0,0 +1,30 @@
+Fixed host contamination of include files
+
+python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
+
+Also, don't use icu-config
+
+Upstream-Status: [inappropriate] OE specific
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: PyICU-2.5/setup.py
+===================================================================
+--- PyICU-2.5.orig/setup.py
++++ PyICU-2.5/setup.py
+@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma
+
+ CONFIGURE_WITH_ICU_CONFIG = {
+ 'darwin': True,
+- 'linux': True,
++ 'linux': False,
+ 'freebsd': False, # not tested
+ 'win32': False, # no icu-config
+ 'sunos5': False, # not tested
+@@ -274,7 +274,6 @@ setup(name="PyICU",
+ ext_modules=[Extension('_icu',
+ [filename for filename in sorted(os.listdir(os.curdir))
+ if filename.endswith('.cpp')],
+- include_dirs=_includes,
+ extra_compile_args=_cflags,
+ extra_link_args=_lflags,
+ libraries=_libraries)],