aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-02-04 09:41:10 +0800
committerKhem Raj <raj.khem@gmail.com>2020-02-03 22:50:59 -0800
commitd2e570b38c9c6a84696206cc14c09a76c3ed25ca (patch)
tree36a4be2a4ac83df25d4a3e5ed122e9d6d49dd969 /meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb
parent14e92f26794fca66b5f7cc7459e2757d9e7bd833 (diff)
downloadmeta-openembedded-d2e570b38c9c6a84696206cc14c09a76c3ed25ca.tar.gz
python3-imageio: add a new package.
ImageIO is a Python library for doing basic I/O operations for images. This recipe is moved from meta-refkit-extra https://layers.openembedded.org/layerindex/recipe/68891/ upgraded from v2.2.0 -> v2.6.0 Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb b/meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb
new file mode 100644
index 0000000000..8fe4b988db
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-imageio_2.6.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Python library that provides an easy interface to read and \
+write a wide range of image data, including animated images, video, \
+volumetric data, and scientific formats."
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d8b7fdd0dff0fd18f35c05365d3d7bf7"
+
+SRC_URI = "git://github.com/imageio/imageio.git;protocol=https"
+SRCREV = "0b161649b3ee108f80bd99466aeab2e65cf82cd8"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "python3-numpy python3-pillow"