aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
diff options
context:
space:
mode:
authorJonathan Richardson via Openembedded-devel <openembedded-devel@lists.openembedded.org>2020-02-14 17:18:35 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit554e52a4aafdfb0da055116c3a141c6e576848ea (patch)
tree3b470d28069f4477a5f2c86300bff4f724844dfb /meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
parent2b135892fafe92f28e0f1719c3ad5f952a4e30df (diff)
downloadmeta-openembedded-554e52a4aafdfb0da055116c3a141c6e576848ea.tar.gz
python3-jdcal: add initial recipe version 1.4.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
new file mode 100644
index 0000000000..c8b5c953b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "This module contains functions for converting between Julian dates and calendar dates"
+DESCRIPTION = "A function for converting Gregorian calendar dates to Julian dates, \
+and another function for converting Julian calendar dates to Julian dates are defined. \
+Two functions for the reverse calculations are also defined."
+
+HOMEPAGE = "https://github.com/phn/jdcal"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc"
+SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"