aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-22 19:50:43 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-24 09:08:00 -0800
commit58c91e724634293aa8ec6a5d1f9ed80095edc91b (patch)
treea711b0bbb8cd21e323f590c3a7073ec0b6d8ea9d /meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb
parentf4ecc2239aea800609926938193ba4811ad8db03 (diff)
downloadmeta-openembedded-58c91e724634293aa8ec6a5d1f9ed80095edc91b.tar.gz
python3-mpmath: Upgrade 1.1.0 -> 1.2.1
Upgrade to release 1.2.1: - Support @ operator for matrix multiplication - Add eta() implementing the Dedekind eta function - Optimized the python_trailing function - Implement unary plus for matrices - Improved calculation of gram_index - Fix a possible division by zero in shanks() - Fixed indexing errors in deHoog, Knight & Stokes inverse laplace transform algorithm - Corrected branch cuts of the elliprj() function in some cases - Fix initialization of iv.matrix from non-interval matrix - Preserve function signatures in PrecisionManager - Implemented float and complex conversions for ivmpf - Fixed issue with scalar-matrix multiplication for interval matrices - Fix estimation of quadrature error with multiple subintervals - Fixed a problem with the defun decorators - Fix eigenvalue sorting by absolute value License-Update: Alter the last clause to ensure that Github recognizes the LICENSE as BSD Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb b/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb
new file mode 100644
index 0000000000..51a7c05847
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mpmath_1.2.1.bb
@@ -0,0 +1,16 @@
+# This recipe is adapted from one in meta-jupyter:
+# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-mpmath_0.19.bb
+
+SUMMARY = "Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE = "https://pypi.org/project/mpmath/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=71970bd3749eebe1bfef9f1efff5b37a"
+
+SRC_URI[sha256sum] = "79ffb45cf9f4b101a807595bcb3e72e0396202e0b1d25d689134b48c4216a81a"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "python3-image"
+
+BBCLASSEXTEND = "native nativesdk"