aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-18 19:30:07 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-20 09:29:46 -0800
commit2d65f273712e57697dc35637baaec25321ae6e01 (patch)
tree9542808cf4243eca1839d77846b09b017d9c3d36 /meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
parent7599690d9c41085c8ab37b87a7dbddafbe5e6279 (diff)
downloadmeta-openembedded-2d65f273712e57697dc35637baaec25321ae6e01.tar.gz
python3-parse: Upgrade 1.18.0 -> 1.19.0
Upgrade to release 1.19.0: - Fix using digit field numbering and types Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-parse_1.19.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.19.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb b/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
new file mode 100644
index 0000000000..b5e0769544
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
+
+SRC_URI[sha256sum] = "9ff82852bcb65d139813e2a5197627a94966245c897796760a3a2a8eb66f020b"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ "
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
+}