aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-03-19 14:01:00 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-19 21:00:06 -0700
commit6cb4e90fcde2d383ebcf656e489ac84d1db422f1 (patch)
treec6972e6b28d8c11e7c800af226872566e5fdfe5b /meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb
parent4ce1fb53568907701b0c9fa63ef96b863269c121 (diff)
downloadmeta-openembedded-6cb4e90fcde2d383ebcf656e489ac84d1db422f1.tar.gz
python3-pillow: add 5.4.1
- Set option by modify setup.py - Do not override do_compile to call `setup.py build_ext', it will missing options at do_install time which causing host contamination ... Found webp/demux.h Found library webpmux at /usr/lib/libwebpmux.so Found library webpdemux at /usr/lib/libwebpdemux.so /usr/include/pthread.h:682:6: error: 'regparm' is not valid on this platform ... Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb b/meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb
new file mode 100644
index 0000000000..746c184491
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_5.4.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c6379001ecb47e2a0420c40177fc1125"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=5.4.x \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+"
+SRCREV ?= "f38f01bbe3a0a9f49ce592c86ff20c01c9655133"
+
+
+inherit setuptools3
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"