aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-02 15:34:54 +0300
committerArmin Kuster <akuster808@gmail.com>2021-04-07 09:37:36 -0700
commit08ae1e71412cfff424977a4833879ea32a4a4c2d (patch)
treee349273d44551aa9d43e47190aa8d8d3d2b68eed /meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb
parentec137ee8b41ef42c8324df608d070498c2d65447 (diff)
downloadmeta-openembedded-08ae1e71412cfff424977a4833879ea32a4a4c2d.tar.gz
python3-pillow: Upgrade 8.1.2 -> 8.2.0
Upgrade to release 8.2.0: - Added getxmp() method - Add ImageShow support for GraphicsMagick - Do not load transparent pixels from subsequent GIF frames - Use LZW encoding when saving GIF images - Set all transparent colors to be equal in quantize() - Allow PixelAccess to use Python __int__ when parsing x and y - Removed Image._MODEINFO - Add preserve_tone option to autocontrast - Fixed linear_gradient and radial_gradient I and F modes - Add support for reading TIFFs with PlanarConfiguration=2 - Deprecated categories - Do not premultiply alpha when resizing with Image.NEAREST resampling - Dynamically link FriBiDi instead of Raqm - Allow fewer PNG palette entries than the bit depth maximum when saving - Use duration from info dictionary when saving WebP - Stop flattening EXIF IFD into getexif() - Replaced tiff_deflate with tiff_adobe_deflate compression when saving TIFF images - Save ICC profile from TIFF encoderinfo - Moved RGB fix inside ImageQt class - Allow alpha_composite destination to be negative - Ensure file is closed if it is opened by ImageQt.ImageQt - Added ImageDraw rounded_rectangle method - Added IPythonViewer - Only draw each rectangle outline pixel once - Use mmap instead of built-in Win32 mapper - Handle PCX images with an odd stride - Only read different sizes for "Large Thumbnail" MPO frames - Added PyQt6 support - Changed Image.open formats parameter to be case-insensitive - Deprecate Tk/Tcl 8.4, to be removed in Pillow 10 (2023-01-02) - Added tk version to pilinfo - Support for ignoring tests when running valgrind - OSS-Fuzz support Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> (cherry picked from commit 0fc9235bbb8f4df0ac7b33f0b875e1fc36e1e563) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb b/meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb
new file mode 100644
index 0000000000..3241230d13
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_8.2.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0337b116233da4616ae9fdb130bf6f1a"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=8.2.x \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+"
+SRCREV ?= "e0e353c0ef7516979a9aedce3792596649ce4433"
+
+inherit setuptools3
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"
+
+CVE_PRODUCT = "pillow"
+
+S = "${WORKDIR}/git"
+
+RPROVIDES_${PN} += "python3-imaging"
+
+BBCLASSEXTEND = "native"