aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-07-16 14:27:28 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-20 09:27:56 -0700
commit485bf0a7308ca6d32d4a3ed9f0902915be6d3fe4 (patch)
tree14199224efda85d11a55ada8011c0c7f487d812b /meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb
parent04701ddaa77e77e64eea29f63e3025e83b95099a (diff)
downloadmeta-openembedded-485bf0a7308ca6d32d4a3ed9f0902915be6d3fe4.tar.gz
python3-protobuf: upgrade 3.17.0 -> 3.17.3
C++ Introduce FieldAccessListener. Stop emitting boilerplate {Copy/Merge}From in each ProtoBuf class Fixed some uninitialized variable warnings in generated_message_reflection.cc. Kotlin Fix duplicate proto files error (#8699) Java Fixed parser to check that we are at a proper limit when a sub-message has finished parsing. General Support M1 (#8557) Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb
new file mode 100644
index 0000000000..b3f9f6f21b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.17.3.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Protocol Buffers"
+HOMEPAGE = "https://developers.google.com/protocol-buffers/"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "72804ea5eaa9c22a090d2803813e280fb273b62d5ae497aaf3553d141c4fdd7b"
+
+# http://errors.yoctoproject.org/Errors/Details/184715/
+# Can't find required file: ../src/google/protobuf/descriptor.proto
+CLEANBROKEN = "1"
+
+UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
+
+DEPENDS += "protobuf"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-unittest \
+"
+
+# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native nativesdk"
+
+DISTUTILS_BUILD_ARGS += "--cpp_implementation"
+DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
+
+do_compile_prepend_class-native () {
+ export KOKORO_BUILD_NUMBER="1"
+}