aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 14:39:16 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commit202249f19b00fe5b7705e3fda84951d3738c416c (patch)
treedc2ff5d4833f733f2b7a14badbc680e91b46be60 /meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
parente2292fd8c52bb14e1d65e970b8e120dc866657ec (diff)
downloadmeta-openembedded-202249f19b00fe5b7705e3fda84951d3738c416c.tar.gz
python-pymysql: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
index 13774bd632..6a64ccb161 100644
--- a/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-pymysql.inc
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
+SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"
+
+PYPI_PACKAGE = "PyMySQL"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"