aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-07 09:39:52 +0000
committerKhem Raj <raj.khem@gmail.com>2020-04-07 09:10:38 -0700
commit51a3331c4e8a2e4653cf3aea21d24822dc521c9c (patch)
treebecf28a33dc442dc7591069c78477221a84717b9 /meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
parente67fd5533fbd26a99bef911b89b757c36c0a96f0 (diff)
downloadmeta-openembedded-51a3331c4e8a2e4653cf3aea21d24822dc521c9c.tar.gz
python3-pyscaffold: move recipe to proper location
Initial submission was performed on incorrect path, move the recipe under [meta-python] folder. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb b/meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
new file mode 100644
index 0000000000..dbd222f549
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python project template generator with batteries included"
+DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
+After installation, it provides a new command [putup], which could be \
+used to create template Projects."
+
+HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "PyScaffold"
+
+SRC_URI[md5sum] = "6769d2a26a9d1f3038944b8fbfe728ff"
+SRC_URI[sha256sum] = "96c3e7f5529df0b5b351e879a141e1e5c9f26211f30d493c23d8c09d9d610a6f"
+
+BBCLASSEXTEND = "native nativesdk"