aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 15:59:30 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-23 10:45:31 -0700
commitb32b4347244b043f442b860550c21f78f34f5e5c (patch)
tree5f465d4cb7340c45f5d808884c75dc73908b41f9 /meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb
parentfa2d3338fb87a38a66d11735b876ce2320045b0d (diff)
downloadmeta-openembedded-b32b4347244b043f442b860550c21f78f34f5e5c.tar.gz
meta-python: Add python3-fastjsonschema and its dependencies
python3-fastjsonschema claims to be fastest Python implementation of JSON schema it however needs additional packages which are also added here, since they are all dependent, its added in single commit so backporting is simpler Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb b/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb
new file mode 100644
index 0000000000..5fb11ddb7f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-benchmark_3.4.1.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "A ``pytest`` fixture for benchmarking code. It will group the tests into rounds that are calibrated to the chosen timer."
+HOMEPAGE = "https://github.com/ionelmc/pytest-benchmark"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9c5c2c74370826468065c5702b8a1fcf"
+
+SRC_URI[sha256sum] = "40e263f912de5a81d891619032983557d62a3d85843f9a9f30b98baea0cd7b47"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-core python3-py-cpuinfo python3-pytest python3-aspectlib"
+
+BBCLASSEXTEND = "native nativesdk"