aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-26 16:20:09 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-28 12:36:49 -0700
commit6a724ae0d66f84f75e49613be9b3c9938bd3c638 (patch)
tree686101bd4802f6fa18c2de4845acf969344fde1d /meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb
parent2f65b7197355a4a0791cf84bd9c49a8d9eef760b (diff)
downloadmeta-openembedded-6a724ae0d66f84f75e49613be9b3c9938bd3c638.tar.gz
python3-pytest-html: Update 1.6 -> 2.1.1
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb b/meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb
new file mode 100644
index 0000000000..27b768155e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-html_2.1.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "pytest plugin for generating html reports from test results"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://../pytest-html.LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+# Per README.rst the license statement is fetched from
+# https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE
+SRC_URI += "https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE;name=license;downloadfilename=pytest-html.LICENSE"
+SRC_URI[license.md5sum] = "5d425c8f3157dbf212db2ec53d9e5132"
+SRC_URI[license.sha256sum] = "2bfdca60adf803108d4c7f009000bea76ad00e621e163197881b0eaae91b530e"
+
+SRC_URI[sha256sum] = "6a4ac391e105e391208e3eb9bd294a60dd336447fd8e1acddff3a6de7f4e57c5"
+
+
+PYPI_PACKAGE = "pytest-html"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"