aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-07 00:06:58 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-08 08:42:20 -0800
commit4ab083606bbec87b3a8a9ca52b45ebc6003ea9f0 (patch)
tree737d79f5ca1e5f9cde4bb6a4a05312e441680874 /meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb
parent7dde75fdf04e5f6c7fa2b8531c6f02b5a3c49e7c (diff)
downloadmeta-openembedded-4ab083606bbec87b3a8a9ca52b45ebc6003ea9f0.tar.gz
python3-pytest-metadata: Upgrade 1.10.0 -> 1.11.0
Upgrade to release 1.11.0: - Provide a session fixture to include metadata in Junit XMLs as property tags Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb
new file mode 100644
index 0000000000..a1b62d16e4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.11.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "pytest-metadata is a plugin that allowed for accessing pytest metadata"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+SRC_URI[sha256sum] = "71b506d49d34e539cc3cfdb7ce2c5f072bea5c953320002c95968e0238f8ecf1"
+
+PYPI_PACKAGE = "pytest-metadata"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"