aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests_2.24.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-01 17:22:39 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:19:27 -0700
commitb9ddcca7a9492898669b82840d72fa8d72bf3cd0 (patch)
tree9a38f79a876c72ddc9903d9dd01a28cf5f0c5e8e /meta-python/recipes-devtools/python/python3-requests_2.24.0.bb
parent49051c7d4ca2db31771d629f85a0a2e130dd3aad (diff)
downloadmeta-openembedded-b9ddcca7a9492898669b82840d72fa8d72bf3cd0.tar.gz
python3-requests: Upgrade 2.23.0 -> 2.24.0
Upgrade to release 2.24.0: - pyOpenSSL TLS implementation is now only used if Python either doesn't have an ssl module or doesn't support SNI. Previously pyOpenSSL was unconditionally used if available. This applies even if pyOpenSSL is installed via the requests[security] extra. - Redirect resolution should now only occur when allow_redirects is True. - No longer perform unnecessary Content-Length calculation for requests that won’t use it. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests_2.24.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.24.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.24.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.24.0.bb
new file mode 100644
index 0000000000..de9a53584b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.24.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=19b6be66ed463d93fa88c29f7860bcd7"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-requests:"
+
+SRC_URI[md5sum] = "b54bff26a389e5932e8b1c4983a99ce7"
+SRC_URI[sha256sum] = "b3559a131db72c33ee969480840fff4bb6dd111de7dd27c8ee1f820f4f00231b"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-ndg-httpsclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna \
+"
+
+CVE_PRODUCT = "requests"
+
+BBCLASSEXTEND = "native nativesdk"