aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-09-25 04:23:42 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-27 11:34:15 -0700
commite177fb82216aebbbab56ed4e5608223139e915d4 (patch)
tree2fe134eab5cc756807f208f1d2f780a90b0db3d3 /meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
parent81a7b2cdf31545750d29c046687de0d6564317a5 (diff)
downloadmeta-openembedded-e177fb82216aebbbab56ed4e5608223139e915d4.tar.gz
python3-robotframework: upgrade 4.1 -> 4.1.1
Robot Framework 4.1.1 is mostly a bug fix release, but it also adds official Python 3.10 support. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb b/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
new file mode 100644
index 0000000000..d715f35135
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "A Python generic test automation framework"
+DESCRIPTION = "Generic open source test atomation framework for acceptance\
+testing and acceptance test-driven development (ATDD). It has easy-to-use\
+tabular test data syntax and it utilizes the keyword-driven testing approach.\
+Its testing capabilities can be extended by test libraries implemented either\
+with Python or Java, and users can create new higher-level keywords from\
+existing ones using the same syntax that is used for creating test cases."
+HOMEPAGE = "http://robotframework.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE_EXT = "zip"
+
+SRC_URI[sha256sum] = "663f84c177b2fa9b3b782939e31637a057a33f3a4b29067812f1259b7f4bad35"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"