aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:48 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit581a31f56f108c61c4e0b7057845484ba82f0ee8 (patch)
treea9b2a6a2ce9b383e0903b584a3cd4baf655e07ff /meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb
parent04493d62806de5bc2fae6edc8d7d0f0dd673c07a (diff)
downloadmeta-openembedded-581a31f56f108c61c4e0b7057845484ba82f0ee8.tar.gz
python-sentry-sdk: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb
index 840df93404..894e1f9020 100644
--- a/meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_0.14.0.bb
@@ -1,2 +1,12 @@
-inherit setuptools3
-require python-sentry-sdk.inc
+SUMMARY = "The new Python SDK for Sentry.io"
+DESCRIPTION = "This is the next line of the Python SDK \
+for Sentry, intended to replace the raven package on PyPI."
+HOMEPAGE = "https://github.com/getsentry/sentry-python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0c79f8d3c91fc847350efd28bfe0a341"
+
+SRC_URI[md5sum] = "2d5cc43c8a178134b739c77439d1f26b"
+SRC_URI[sha256sum] = "8e2d38dc58dc992280487e553ec3d97a424e4d179f4fad802ef3b08f64ccf4d8"
+
+PYPI_PACKAGE = "sentry-sdk"
+inherit pypi setuptools3