aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-27 12:40:13 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-04 11:09:26 -0800
commit551e72b9d313cf443fbb3e420710d19f783c6462 (patch)
tree5dcd1f6501c596c3f5bbe6f4fe84b5d80113d54d /meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
parent3a7670013b17cff18ccd26816500d14cb4036f8d (diff)
downloadmeta-openembedded-551e72b9d313cf443fbb3e420710d19f783c6462.tar.gz
python3-sh: Upgrade 1.14.0 -> 1.14.1
Upgrade to release 1.14.1: - bugfix where setting _ok_code to not include 0, but 0 was the exit code Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sh_1.14.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sh_1.14.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb b/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
new file mode 100644
index 0000000000..c7b50c21a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[md5sum] = "50fc0a2953930ed8d0f6570835e88abf"
+SRC_URI[sha256sum] = "39aa9af22f6558a0c5d132881cf43e34828ca03e4ae11114852ca6a55c7c1d8e"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-tests \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+"