aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-09-06 16:41:32 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-07 10:02:11 -0700
commit549ff5368e874081c00abe738cba63683456b9c4 (patch)
tree13ae2c6d524c0d336c6f87aef33ffc8ca187fca1 /meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb
parente62d3b769413808397148175d84ae0530ba35e57 (diff)
downloadmeta-openembedded-549ff5368e874081c00abe738cba63683456b9c4.tar.gz
python3-traitlets: upgrade 5.0.5 -> 5.1.0
Traitlets 5.1 brings a couple of updates and changes to traitlets, and is recommended for all users. What follow is a non-exhaustive list of changes: - Removal of the ``ipython_genutils`` dependency, this should remove any direct and indirect reliance on ``nose`` and prepare traitlets 5.1 for Python 3.10 and above compatibility, some test suite changes also accommodate Python 3.10 changes. If you package traitlets downstream, make sure to remove this dependency. - Removal of ``ipython_genutils`` may have change the default encoding detected for the command line argument parsing when not utf-8. We expect this to affect a small portion of older windows version. If you encounter issue let us know. - Stop recommendation of ``CUnicode`` in some circumstances as it's deprecated. - Our test suite is now using GitHub action instead of travis CI. If you are packaging downstream using the git repository, you may have to exclude the ``.github`` folder now, and can remove exclusion of - It fixes a parsing issue for list of one single element on the CLI. - We reserve the right to remove official support for Python 3.7 in subsequent minor revisions. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb b/meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb
new file mode 100644
index 0000000000..da234215ea
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-traitlets_5.1.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Traitlets Python config system"
+HOMEPAGE = "http://ipython.org"
+AUTHOR = "IPython Development Team <ipython-dev@scipy.org>"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING.md;md5=eec4de4d599518742e54e75954e33b46"
+
+PYPI_PACKAGE = "traitlets"
+
+SRC_URI[sha256sum] = "bd382d7ea181fbbcce157c133db9a829ce06edffe097bcf3ab945b435452b46d"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-ipython-genutils \
+ ${PYTHON_PN}-decorator \
+"
+
+inherit setuptools3 pypi