aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-07-20 11:53:52 -0700
committerArmin Kuster <akuster808@gmail.com>2021-07-30 16:20:20 -0700
commit5a4b2ab29d38c02535f24d5308cc40615739f557 (patch)
tree12ff9e6bcb12e121beaf44f44e34ad9ae1a8ab6f /meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb
parent88813d34dd665cf90403716b88db2f0e0ec78d76 (diff)
downloadmeta-openembedded-5a4b2ab29d38c02535f24d5308cc40615739f557.tar.gz
python3-urllib3: Upgrade 1.26.4 -> 1.26.5
Upgrade to release 1.26.5: - Fixed deprecation warnings emitted in Python 3.10. - Updated vendored six library to 1.16.0. - Improved performance of URL parser when splitting the authority component. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Fixes CVE 2021-33503. (cherry picked from commit bb39c29a46e44fcc082aed0ce8772f4267a41d2d) Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb b/meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb
new file mode 100644
index 000000000..f2fb33c6d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-urllib3_1.26.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
+
+SRC_URI[sha256sum] = "a7acd0977125325f516bda9735fa7142b909a8d01e8b2e4c8108d0984e6e0098"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-certifi \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-threading \
+"
+
+CVE_PRODUCT = "urllib3"
+
+BBCLASSEXTEND = "native nativesdk"