aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-01-29 13:12:41 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commitac179bc18eddaa2e10191908e5518c9f94346d81 (patch)
tree1b5c6043ef09e8d8f490c286aba04d3325bc8769 /meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb
parentee93134f9f52f7817cb1ffcf18bc03ba89e5f823 (diff)
downloadmeta-openembedded-ac179bc18eddaa2e10191908e5518c9f94346d81.tar.gz
python3-vcversioner: remove egg generation
Remove egg file build. This got introduced with commit fb1696372ff9 ("python-vcversioner: Error Fix for recipes depend on python-vcversioner"). However, it seems that this was actually not related to the missing egg file, but to the back then missing depends on python-vcversioner-native. This got fixed in commit 12d09665bbee ("python-jsonschema, python3-jsonschema: add vcversioner-native dependency"). It also causes issue when trying to build a reproducible build with a timestamp of 0 due to limitations of the ZIP file format used by the Python egg packaging. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb
index f6372c8d56..149078c51b 100644
--- a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb
@@ -9,12 +9,4 @@ SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa
inherit pypi setuptools3
-do_compile_append() {
- ${PYTHON} setup.py -q bdist_egg --dist-dir ./
-}
-
-do_install_append() {
- install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
-}
-
BBCLASSEXTEND = "native"