aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 17:21:19 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:45:54 -0700
commitdda6ccce1785865a3d3b91502e53a1678c998eda (patch)
tree39fbf5e3d27114158fc1c2347e189b3e18b24293 /meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
parent8effb46af046e1aab381d2461480d76e4c7fe811 (diff)
downloadmeta-openembedded-dda6ccce1785865a3d3b91502e53a1678c998eda.tar.gz
python-xlrd: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb33
1 files changed, 31 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb b/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
index b7bd969c71..571dba6fa8 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
@@ -1,2 +1,31 @@
-inherit pypi setuptools3
-require python-xlrd.inc
+SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\
+ versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \
+Strong support for Excel dates. Unicode-aware."
+HOMEPAGE = "http://www.python-excel.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5f4244d51fcc1e7cc2d43e96891b2f80"
+
+SRC_URI[md5sum] = "e5d5b96924d791b22898b622eb3e918e"
+SRC_URI[sha256sum] = "546eb36cee8db40c3eaa46c351e67ffee6eeb5fa2650b71bc4c758a29a1b29b2"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+inherit ptest pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/examples
+ cp -rf ${S}/examples/* ${D}${PTEST_PATH}/examples/
+}
+
+BBCLASSEXTEND = "native nativesdk"