aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-01 16:39:58 +0300
committerArmin Kuster <akuster808@gmail.com>2021-04-07 09:37:36 -0700
commitfb2393b406bb3b23fe5c43b41fea6118e703a063 (patch)
tree63c57c1836f0c4a620680a61d2a2e8e050a69b13 /meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb
parent6e4d464c883c17bca3f8bc0b4c469c64c290db70 (diff)
downloadmeta-openembedded-fb2393b406bb3b23fe5c43b41fea6118e703a063.tar.gz
python3-xlsxwriter: Upgrade 1.3.7 -> 1.3.8
Upgrade to release 1.3.8: - Added ability to add accessibility options "description" and "decorative" to images via :func:`insert_image`. - Added fix for datetime.timedelta values that exceed the Excel 1900 leap day (timedeltas greater than 59 days, in hours). This is a backward incompatible change. - Added the worksheet :func:`read_only_recommended` method to set the Excel "Read-only Recommended" option that is available when saving a file. - Fixed issue where temp files used in `constant_memory` mode weren't closed/deleted if the workbook object was garbage collected. - Fixed issue where pattern formats without colors were given a default black fill color. - Added option to set a chart crossing to 'min' as well as the existing 'max' option. The 'min' option isn't available in the Excel interface but can be enabled via VBA. License-Update: Updated copyright year. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> (cherry picked from commit 4161ee91c1607d32651b4852f0c3b27f763880ec) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb b/meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb
new file mode 100644
index 0000000000..e89221e5c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xlsxwriter_1.3.8.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python 2 and 3 compatibility library"
+HOMEPAGE = "https://xlsxwriter.readthedocs.io"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e95e368cd6cb090815046688e92d11e"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "XlsxWriter"
+
+SRC_URI[sha256sum] = "2b7e22b1268c2ed85d73e5629097c9a63357f2429667ada9863cd05ff8ee33aa"
+
+BBCLASSEXTEND = "native nativesdk"