aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 17:21:14 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:45:54 -0700
commit8389a281b54ca93d6f66e0fa16df8a69f4181b66 (patch)
tree30d0e0a1864e179b47d4e7468f055d2f1cb40c1f /meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
parenta099159a3601aba4af975e88c68689c3a380473c (diff)
downloadmeta-openembedded-8389a281b54ca93d6f66e0fa16df8a69f4181b66.tar.gz
python-yarl: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb31
1 files changed, 29 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb b/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
index c5df44216b..15d92065d0 100644
--- a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
@@ -1,2 +1,29 @@
-inherit setuptools3
-require python-yarl.inc
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
+
+SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba"
+SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+PYPI_PACKAGE = "yarl"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-idna \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}