aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-05-07 15:48:08 +0800
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:32:43 -0700
commit1e1128683cdc27ce51931658b4402862df0a282c (patch)
tree83403be500b71c2bea716cdbc19e03a36f17de83 /meta-python/recipes-devtools/python
parentfde2510fd5a58316081b407416e8610cb8d2a52b (diff)
downloadmeta-openembedded-1e1128683cdc27ce51931658b4402862df0a282c.tar.gz
python3-pid: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import pid [snip] ModuleNotFoundError: No module named 'fcntl' ModuleNotFoundError: No module named 'logging' ModuleNotFoundError: No module named 'tempfile' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 580ec1e925e07484b46e76f2e7ee09d9b40c19e5) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pid_2.2.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pid_2.2.5.bb b/meta-python/recipes-devtools/python/python3-pid_2.2.5.bb
index b8dd0d7474..ef19478885 100644
--- a/meta-python/recipes-devtools/python/python3-pid_2.2.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pid_2.2.5.bb
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "ad352ee1dc28b9746a15451c0c53e9d7"
SRC_URI[sha256sum] = "96eb7dba326b88f5164bc1afdc986c7793e0d32d7f62366256a3903c7b0614ef"
inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-fcntl ${PYTHON_PN}-logging ${PYTHON_PN}-io"