aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-04-28 10:09:14 -0300
committerKhem Raj <raj.khem@gmail.com>2020-04-28 16:24:07 -0700
commit2b30970845c5671433c7cca66d39aeb39c7cb535 (patch)
treeacaedce8badff2a1b040bd62e14c25fec4a9a935 /meta-python/recipes-devtools/python
parent22d74cb158949dca9008ae0a27fef212bfc2310a (diff)
downloadmeta-openembedded-2b30970845c5671433c7cca66d39aeb39c7cb535.tar.gz
python3-nmap: Add recipe version 1.4.1
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-nmap_1.4.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-nmap_1.4.1.bb b/meta-python/recipes-devtools/python/python3-nmap_1.4.1.bb
new file mode 100644
index 0000000000..80384845df
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nmap_1.4.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "python-nmap is a python library which helps in using nmap port scanner"
+HOMEPAGE = "https://www.nmmapper.com/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS += "${PYTHON_PN}-wheel-native"
+
+PYPI_PACKAGE = "python3-nmap"
+
+SRC_URI[md5sum] = "64a382c870e14b53f2f52b7455996321"
+SRC_URI[sha256sum] = "9b64c5956789f4cac9e8ea2e0de6763dea1cecde1a20ae50a4b4dc5ab0ab6e42"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "nmap ${PYTHON_PN}-requests"