aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-05-12 19:34:18 -0400
committerArmin Kuster <akuster808@gmail.com>2020-05-20 16:50:08 +0000
commitdcd0496c7992eb35047db3ea864f3bad5c0a4ee1 (patch)
tree76f2eebcc15a06b24bb67f7c176f6264858e3f12 /meta-python/recipes-devtools/python
parent3bf3346f206d136c0a60b956d0bb05088f23443d (diff)
downloadmeta-openembedded-dcd0496c7992eb35047db3ea864f3bad5c0a4ee1.tar.gz
python3-werkzeug: add python3-logging to RDEPENDS
werkzeug relies on the logging module, but it is not in RDEPENDS, so add it: |Python 3.8.2 (default, Apr 27 2020, 08:51:00) |[GCC 9.3.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import werkzeug |Traceback (most recent call last): |File "<stdin>", line 1, in <module> |File "/usr/lib64/python3.8/site-packages/werkzeug/_init_.py", line 15, in <module> |from .serving import run_simple |File "/usr/lib64/python3.8/site-packages/werkzeug/serving.py", line 50, in <module> |from ._internal import _log |File "/usr/lib64/python3.8/site-packages/werkzeug/_internal.py", line 12, in <module> |import logging |ModuleNotFoundError: No module named 'logging' Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f92b959f4a52ec7596aace92c8d37a370a132f30) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
index b54399e1c8..58735c1c02 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.1.bb
@@ -26,6 +26,7 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-html \
${PYTHON_PN}-io \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
${PYTHON_PN}-netclient \
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \