aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-14 17:23:36 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-17 08:52:24 -0700
commit38daf98db7eb7d7480cdc7e8d4bedbe42f655e21 (patch)
tree793ed7a1c70bb29817805bfeada243fc46d9dc32 /meta-python/recipes-devtools/python
parent56e334fade77685b7d30a3e3560a2ae753059774 (diff)
downloadmeta-openembedded-38daf98db7eb7d7480cdc7e8d4bedbe42f655e21.tar.gz
python3-deprecated: Add recipe
Python @deprecated decorator to deprecate old python classes, functions or methods. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-deprecated_1.2.12.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-deprecated_1.2.12.bb b/meta-python/recipes-devtools/python/python3-deprecated_1.2.12.bb
new file mode 100644
index 0000000000..4651a8ae35
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-deprecated_1.2.12.bb
@@ -0,0 +1,9 @@
+SUMMARY = "Python @deprecated decorator to deprecate old python classes, functions or methods."
+HOMEPAGE = "https://deprecated.readthedocs.io/en/latest/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=44288e26f4896bdab14072d4fa35ff01"
+
+PYPI_PACKAGE = "Deprecated"
+SRC_URI[sha256sum] = "6d2de2de7931a968874481ef30208fd4e08da39177d61d3d4ebdf4366e7dbca1"
+
+inherit pypi setuptools3