aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-24 13:11:51 +0100
committerKhem Raj <raj.khem@gmail.com>2022-05-29 06:39:14 -0700
commit4aebf7e4b226621f4ffe531b8a34510cf3b13742 (patch)
treeb4dd418cf23faa59d614273e0f294e4912071fb1 /meta-python/recipes-devtools/python
parent07c2e3273c93d9585b7656ffe3518d147f1e56ae (diff)
downloadmeta-openembedded-4aebf7e4b226621f4ffe531b8a34510cf3b13742.tar.gz
python3-hatchling: add new recipe and build class
Hatchling is the build backend used by the Hatch tool. Add the recipe and a pep517 build class. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-hatchling_1.3.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-hatchling_1.3.0.bb b/meta-python/recipes-devtools/python/python3-hatchling_1.3.0.bb
new file mode 100644
index 0000000000..a6550a9732
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-hatchling_1.3.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The extensible, standards compliant build backend used by Hatch"
+HOMEPAGE = "https://hatch.pypa.io/latest/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
+
+inherit pypi python_hatchling
+
+DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native"
+DEPENDS:remove:class-native = "python3-hatchling-native"
+
+SRC_URI[sha256sum] = "1401d45d3dd6a5910f64d539acaa943486d5e8b7dda1a97f2b0040fdddc5b85e"
+
+# Until we have a proper tool to invoke PEP517 builds, hatchling can't
+# bootstrap itself automatically.
+PEP517_BUILD_API = "hatchling.ouroboros"
+
+do_compile:prepend() {
+ export PYTHONPATH=src
+}
+
+BBCLASSEXTEND = "native nativesdk"