aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-29 14:00:24 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:57 -0800
commit5bf4a6fece53f4d2a170f01048bb4702adf4a959 (patch)
treea7b73ccaa60b757cbb9ffb38f09f4d83cbb4c49a /meta-python/recipes-devtools/python
parent72ba5a366410789ef45311be4c36a079941fa037 (diff)
downloadmeta-openembedded-5bf4a6fece53f4d2a170f01048bb4702adf4a959.tar.gz
python-itsdangerous: fix RDEPENDS to work on minimal python install
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-itsdangerous.inc5
-rw-r--r--meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb4
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-itsdangerous.inc b/meta-python/recipes-devtools/python/python-itsdangerous.inc
index 73951fa561..84f9e7742d 100644
--- a/meta-python/recipes-devtools/python/python-itsdangerous.inc
+++ b/meta-python/recipes-devtools/python/python-itsdangerous.inc
@@ -7,3 +7,8 @@ SRC_URI[md5sum] = "a3d55aa79369aef5345c036a8a26307f"
SRC_URI[sha256sum] = "cbb3fcf8d3e33df861709ecaf89d9e6629cff0a217bc2848f1b41cd30d360519"
CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-simplejson \
+ ${PYTHON_PN}-netclient \
+"
diff --git a/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
index 0e156be2f7..8c99cb4ca7 100644
--- a/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
+++ b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools
require python-itsdangerous.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-zlib \
+"
diff --git a/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb b/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb
index cd3082528c..a71c20f0e0 100644
--- a/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb
+++ b/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools3
require python-itsdangerous.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-compression \
+"