aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-05-11 10:07:11 +0800
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:25:56 -0700
commitc01423e4ba188d7787f0f7c2d5322fbe03e975b3 (patch)
tree14ca757340f84b6c14a7daa852d07cdd12264cb0 /meta-python/recipes-devtools/python
parent3efefaad13da26160953733042b38d33029cfa3e (diff)
downloadmeta-openembedded-c01423e4ba188d7787f0f7c2d5322fbe03e975b3.tar.gz
python3-paho-mqtt: add package python3-paho-mqtt-examples
package examples under source into python3-paho-mqtt-examples Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb
index d93bc884ee..d002c0fc51 100644
--- a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.5.1.bb
@@ -13,6 +13,17 @@ SRC_URI[sha256sum] = "9feb068e822be7b3a116324e01fb6028eb1d66412bf98595ae72698965
DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+do_install_append() {
+ install -d -m0755 ${D}${datadir}/${BPN}/examples
+ cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
+}
+
+PACKAGES =+ "${PN}-examples"
+
+RDEPENDS_${PN}-examples += "${PN}"
+
+FILES_${PN}-examples = "${datadir}/${BPN}/examples"
+
RDEPENDS_${PN} = "\
${PYTHON_PN}-io \
${PYTHON_PN}-logging \