aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:30 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commite78cf913076ba28633d0ec4540f15820a0d944d2 (patch)
treeadb40c6af2cf6555f9d166eb0d96d0b51a57e745 /meta-python/recipes-devtools/python
parent8d3d5299f463efb5e96404eb9e416199ec66e05c (diff)
downloadmeta-openembedded-e78cf913076ba28633d0ec4540f15820a0d944d2.tar.gz
python{3, }-protobuf: consolidate CLEANBROKEN
Since python-protobuf and python3-protobuf share the same build instructions, it's sane to clarify for both at the same place, that running setup.py clean is wrong in configure stage. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.6.0.bb1
3 files changed, 4 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-python/recipes-devtools/python/python-protobuf.inc
index 6a0568ae62..a1866b351f 100644
--- a/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -10,6 +10,10 @@ inherit pypi
SRC_URI[md5sum] = "074abcceee0d795ba34ad6430f71d0e8"
SRC_URI[sha256sum] = "a37836aa47d1b81c2db1a6b7a5e79926062b5d76bd962115a0e615551be2b48d"
+# http://errors.yoctoproject.org/Errors/Details/184715/
+# Can't find required file: ../src/google/protobuf/descriptor.proto
+CLEANBROKEN = "1"
+
UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
RDEPENDS_${PN} += " \
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb
index dddc9bbb58..f04fc489f0 100644
--- a/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.6.0.bb
@@ -1,6 +1,2 @@
inherit setuptools
require python-protobuf.inc
-
-# http://errors.yoctoproject.org/Errors/Details/184715/
-# Can't find required file: ../src/google/protobuf/descriptor.proto
-CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.6.0.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.6.0.bb
index 53d5528c4b..781d1dc4da 100644
--- a/meta-python/recipes-devtools/python/python3-protobuf_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.6.0.bb
@@ -1,3 +1,2 @@
inherit setuptools3
require python-protobuf.inc
-CLEANBROKEN = "1"