aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-05-12 16:00:17 -0400
committerArmin Kuster <akuster808@gmail.com>2020-05-20 16:50:08 +0000
commit34614aa264bee53c848ca146e237e2825610544a (patch)
tree68564d1c65ab693cfde3435d77b847546ea9e068 /meta-python/recipes-devtools
parent461a5d263bc3cb290fe5690aaf9537a9e78b22f6 (diff)
downloadmeta-openembedded-34614aa264bee53c848ca146e237e2825610544a.tar.gz
python3-pyrsistent: add python3-numbers to RDEPENDS
python3-pyrsistent requires python3-numbers, so add it to RDEPENDS: |Python 3.8.2 (default, Apr 27 2020, 08:51:00) |[GCC 9.3.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import pyrsistent |Traceback (most recent call last): |File "<stdin>", line 1, in <module> |File "/usr/lib64/python3.8/site-packages/pyrsistent/_init_.py", line 3, in <module> |from pyrsistent._pmap import pmap, m, PMap |File "/usr/lib64/python3.8/site-packages/pyrsistent/_pmap.py", line 4, in <module> |from pyrsistent._pvector import pvector |File "/usr/lib64/python3.8/site-packages/pyrsistent/_pvector.py", line 3, in <module> |from numbers import Integral |ModuleNotFoundError: No module named 'numbers' Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 06916cbfbe150561f9d78a32e162780689df5cf7) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
index 5ef7140283..53251aa55c 100644
--- a/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
@@ -9,6 +9,7 @@ SRC_URI[sha256sum] = "cdc7b5e3ed77bed61270a47d35434a30617b9becdf2478af76ad2c6ade
inherit pypi setuptools3
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numbers \
${PYTHON_PN}-six \
"