aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-05-07 16:13:33 +0800
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:32:43 -0700
commite9e00f7bc83d17f0d06a863ebbe015f1aaaa0b2e (patch)
treeaba77de2e6c08cb4a62138c7bfa065783a07e827 /meta-python/recipes-devtools
parent1e1128683cdc27ce51931658b4402862df0a282c (diff)
downloadmeta-openembedded-e9e00f7bc83d17f0d06a863ebbe015f1aaaa0b2e.tar.gz
python3-parallax: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import parallax [snip] ModuleNotFoundError: No module named 'fcntl' ModuleNotFoundError: No module named 'Queue' ModuleNotFoundError: No module named 'getpass' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit e04584ef5ba7ed0abaf5b98c2da00bbeab5b6db8) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-parallax_1.0.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parallax_1.0.5.bb b/meta-python/recipes-devtools/python/python3-parallax_1.0.5.bb
index d658bd621e..60631d43a0 100644
--- a/meta-python/recipes-devtools/python/python3-parallax_1.0.5.bb
+++ b/meta-python/recipes-devtools/python/python3-parallax_1.0.5.bb
@@ -8,4 +8,6 @@ SRC_URI[sha256sum] = "e9e4dc500f1306a638df0f19d4ef976a623b260fc614c55cb1fd0d8410
inherit pypi setuptools3
+RDEPENDS_${PN} += "${PYTHON_PN}-fcntl ${PYTHON_PN}-threading ${PYTHON_PN}-unixadmin"
+
BBCLASSEXTEND = "native nativesdk"