aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:39 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commit63ca0ba5ae586474fe312aa1073c73afae302ddd (patch)
tree115f092c81dc393ba735c8e02a80226c6ad6b520 /meta-python/recipes-devtools
parent4151e38933865d9306d027aca0c045d788ca52f3 (diff)
downloadmeta-openembedded-63ca0ba5ae586474fe312aa1073c73afae302ddd.tar.gz
python-jinja2: add recipe
Jinja2 is a stand-alone template engine for Python. Copied from commit 00862f55be214e2247ad5aba3ab06a34afb20598 in meta-cloud-services/meta-openstack and updated to version 2.7.3. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2_2.7.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.7.3.bb b/meta-python/recipes-devtools/python/python-jinja2_2.7.3.bb
new file mode 100644
index 0000000000..e66077af17
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jinja2_2.7.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
+HOMEPAGE = "https://pypi.python.org/pypi/Jinja2"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=20c831f91dd3bd486020f672ba2be386"
+
+PR = "r0"
+SRCNAME = "Jinja2"
+
+SRC_URI = "https://pypi.python.org/packages/source/J/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "b9dffd2f3b43d673802fe857c8445b1a"
+SRC_URI[sha256sum] = "2e24ac5d004db5714976a04ac0e80c6df6e47e98c354cb2c0d82f8879d4f8fdb"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-io python-pickle python-crypt python-math python-netclient python-re python-textutils python-lang python-pprint python-shell python-markupsafe"