aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-09-22 08:55:30 -0700
committerKhem Raj <raj.khem@gmail.com>2021-09-24 08:11:53 -0700
commited262ee60acf9bba7c2168f423b1f68ce2c6e79b (patch)
tree73a44bb9e2a4d73c6cfb1f115479f1f2f72c2903 /meta-python/recipes-devtools
parent9388e0f23cb26f0ed1120ab39642d14c6e80dcc0 (diff)
downloadmeta-openembedded-ed262ee60acf9bba7c2168f423b1f68ce2c6e79b.tar.gz
python3-icu: Inherit pkgconfig
Fixes RuntimeError: Please install pkg-config on your system or set the PYICU_CFLAGS environment variable to the flags required by the C++ compiler to find the header files for ICU, and possibly -std=c++11 if using ICU version >= 60 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.7.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
index 4c064c3d4c..2433a8c9d3 100644
--- a/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
@@ -3,11 +3,11 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://setup.py;beginline=244;endline=252;md5=3e00c41c6d04310707992b93307a224f"
-DEPENDS += "pkgconfig icu"
+DEPENDS += "icu"
PYPI_PACKAGE = "PyICU"
SRC_URI[sha256sum] = "1382869b22d91cc99274f9b525fa7d9199b44d9007ff0036a09747839a01e9dc"
SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
-inherit pypi setuptools3
+inherit pkgconfig pypi setuptools3