aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-09-04 10:41:00 -0700
committerKhem Raj <raj.khem@gmail.com>2021-09-07 10:02:11 -0700
commit346fff50f9328d3952121225dec07e241863a06b (patch)
treee21a5a3bd66fd98978ec2306b8fb9334751f4784 /meta-python/recipes-devtools
parent383fb93e8bc8fea089d2f3c47e264e63bb103f9a (diff)
downloadmeta-openembedded-346fff50f9328d3952121225dec07e241863a06b.tar.gz
python3-kivy: Check for x11 and opengl before enabling the recipe
Fixes ERROR: Nothing PROVIDES 'libsdl2-ttf' (but meta-openembedded/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb DEPENDS on or otherwise requires it) libsdl2-ttf was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) ERROR: Nothing RPROVIDES 'python3-kivy-dev' (but meta-openembedded/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'python3-kivy-dev' NOTE: Runtime target 'python3-kivy-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-kivy-dev'] ERROR: Nothing RPROVIDES 'python3-kivy' (but meta-openembedded/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'python3-kivy' NOTE: Runtime target 'python3-kivy' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-kivy'] Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com> Cc: William Huang <whuang8933@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb b/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb
index 63c2ae7334..d046489021 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://kivy.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0c851d60495c7e27225a819e179208a"
-inherit setuptools3
+inherit setuptools3 pkgconfig features_check
SRC_URI = "\
git://github.com/kivy/kivy.git;protocol=git;\
@@ -42,6 +42,8 @@ export KIVY_GRAPHICS
KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
export KIVY_CROSS_SYSROOT
+REQUIRED_DISTRO_FEATURES += "x11 opengl"
+
DEPENDS += " \
gstreamer1.0 \
gstreamer1.0-python \