aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-19 14:17:45 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:46 +0000
commit60d327c66570b770a18cd1b06526693241170a56 (patch)
tree9ca1ee8077fb4ce00197498b986635454eb08257 /meta-python/recipes-devtools
parent0c4f3a3d8cf6caf7f9fd67e465e1e25ab8dcda40 (diff)
downloadmeta-openembedded-60d327c66570b770a18cd1b06526693241170a56.tar.gz
python-twisted: update version to 17.5.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-twisted_17.5.0.bb (renamed from meta-python/recipes-devtools/python/python-twisted_13.2.0.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted/0001-initsendmsg-Return-NULL-on-error.patch76
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-twisted_13.2.0.bb)3
4 files changed, 12 insertions, 82 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index d734e03b36..bdb3c604ea 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -5,10 +5,10 @@ HOMEPAGE = "http://www.twistedmatrix.com"
#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5602d7228daf59a16f0f1b2640c46bca"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8a9c2fbfcba7d70504e3ba545e1820ed"
-SRC_URI[md5sum] = "83fe6c0c911cc1602dbffb036be0ba79"
-SRC_URI[sha256sum] = "095175638c019ac7c0604f4c291724a16ff1acd062e181b01293bf4dcbc62cf3"
+SRC_URI[md5sum] = "cd5c287802dcbaf7be15cf937c922b71"
+SRC_URI[sha256sum] = "f198a494f0df2482f7c5f99d7f3eef33d22763ffc76641b36fec476b878002ea"
PYPI_PACKAGE = "Twisted"
PYPI_PACKAGE_EXT = "tar.bz2"
@@ -72,12 +72,14 @@ FILES_${PN} = ""
FILES_${PN}-test = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
"
FILES_${PN}-protocols = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
"
FILES_${PN}-zsh = " \
@@ -180,6 +182,9 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
"
FILES_${PN}-lore = " \
@@ -236,6 +241,10 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
"
+FILES_${PN}-doc += " \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
+"
+
RDEPENDS_{PN}-src = "${PN}"
FILES_${PN}-src = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
diff --git a/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb b/meta-python/recipes-devtools/python/python-twisted_17.5.0.bb
index 3b4511077f..3b4511077f 100644
--- a/meta-python/recipes-devtools/python/python-twisted_13.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-twisted_17.5.0.bb
diff --git a/meta-python/recipes-devtools/python/python3-twisted/0001-initsendmsg-Return-NULL-on-error.patch b/meta-python/recipes-devtools/python/python3-twisted/0001-initsendmsg-Return-NULL-on-error.patch
deleted file mode 100644
index d4cf345541..0000000000
--- a/meta-python/recipes-devtools/python/python3-twisted/0001-initsendmsg-Return-NULL-on-error.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 890d039f067d52a0ab77b561d40da13f0c135634 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 3 Aug 2017 11:24:43 -0700
-Subject: [PATCH] initsendmsg: Return NULL on error
-
-Fixes a clang error
-
-sendmsg.c:129:9: error: non-void function 'initsendmsg' should return a value [-Wreturn-type]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- twisted/python/sendmsg.c | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/twisted/python/sendmsg.c b/twisted/python/sendmsg.c
-index 9f2fd8c..9c080e1 100644
---- a/twisted/python/sendmsg.c
-+++ b/twisted/python/sendmsg.c
-@@ -126,7 +126,7 @@ PyMODINIT_FUNC initsendmsg(void) {
- module = Py_InitModule3("sendmsg", sendmsg_methods, sendmsg_doc);
-
- if (!module) {
-- return;
-+ return NULL;
- }
-
- /*
-@@ -135,39 +135,39 @@ PyMODINIT_FUNC initsendmsg(void) {
- */
-
- if (-1 == PyModule_AddIntConstant(module, "SCM_RIGHTS", SCM_RIGHTS)) {
-- return;
-+ return NULL;
- }
-
-
- /* BSD, Darwin, Hurd */
- #if defined(SCM_CREDS)
- if (-1 == PyModule_AddIntConstant(module, "SCM_CREDS", SCM_CREDS)) {
-- return;
-+ return NULL;
- }
- #endif
-
- /* Linux */
- #if defined(SCM_CREDENTIALS)
- if (-1 == PyModule_AddIntConstant(module, "SCM_CREDENTIALS", SCM_CREDENTIALS)) {
-- return;
-+ return NULL;
- }
- #endif
-
- /* Apparently everywhere, but not standardized. */
- #if defined(SCM_TIMESTAMP)
- if (-1 == PyModule_AddIntConstant(module, "SCM_TIMESTAMP", SCM_TIMESTAMP)) {
-- return;
-+ return NULL;
- }
- #endif
-
- module = PyImport_ImportModule("socket");
- if (!module) {
-- return;
-+ return NULL;
- }
-
- sendmsg_socket_error = PyObject_GetAttrString(module, "error");
- if (!sendmsg_socket_error) {
-- return;
-+ return NULL;
- }
- }
-
---
-2.13.4
-
diff --git a/meta-python/recipes-devtools/python/python3-twisted_13.2.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.5.0.bb
index 57406cd527..98016cca39 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_13.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.5.0.bb
@@ -1,9 +1,6 @@
inherit pypi setuptools3
require python-twisted.inc
-SRC_URI += "file://0001-initsendmsg-Return-NULL-on-error.patch \
- "
-
RDEPENDS_${PN}-core = "python3-core python3-zopeinterface python3-lang"
FILES_${PN}-core_append += " \