aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:36 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commit49b6db7e66bbff7ec0c1ddbd746c656004527db5 (patch)
tree86076e9004a9d167a85d066e9a6b5fe58304d3d2 /meta-python/recipes-devtools
parentaf8aff7b878ec08e3cba9e5fafe58b73f10bda44 (diff)
downloadmeta-openembedded-49b6db7e66bbff7ec0c1ddbd746c656004527db5.tar.gz
Remove deprecated python3-textutils from the RDEPENDS
The python3-textutils package was merged into core as part of the json manifest migration Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2_2.10.bb6
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-netaddr.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb1
9 files changed, 15 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-python/recipes-devtools/python/python-asn1crypto.inc
index 0d3ee41528..2777c215bd 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto.inc
+++ b/meta-python/recipes-devtools/python/python-asn1crypto.inc
@@ -18,7 +18,6 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
${PYTHON_PN}-netclient \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-subprocess \
"
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
index 6af60c2d42..1218519ec6 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
+++ b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-asn1crypto.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-textutils \
+"
diff --git a/meta-python/recipes-devtools/python/python-jinja2.inc b/meta-python/recipes-devtools/python/python-jinja2.inc
index 510765b286..0c0bf0defa 100644
--- a/meta-python/recipes-devtools/python/python-jinja2.inc
+++ b/meta-python/recipes-devtools/python/python-jinja2.inc
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "61ef1117f945486472850819b8d1eb3d"
SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4"
RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-math ${PYTHON_PN}-netclient \
${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
index 06075213f7..5233cf40c0 100644
--- a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
+++ b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
@@ -1,4 +1,8 @@
inherit pypi setuptools
require python-jinja2.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-lang ${PYTHON_PN}-re"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-lang \
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-textutils \
+"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
index 748ef6e2ee..8413692929 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema.inc
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-shell \
${PYTHON_PN}-strict-rfc3339 \
${PYTHON_PN}-subprocess \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-unittest \
"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
index c118f2d8a0..7407616335 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
@@ -7,4 +7,5 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-functools32 \
${PYTHON_PN}-lang \
${PYTHON_PN}-re \
+ ${PYTHON_PN}-textutils \
"
diff --git a/meta-python/recipes-devtools/python/python-netaddr.inc b/meta-python/recipes-devtools/python/python-netaddr.inc
index 486bfc6001..5b6d4dffa1 100644
--- a/meta-python/recipes-devtools/python/python-netaddr.inc
+++ b/meta-python/recipes-devtools/python/python-netaddr.inc
@@ -9,6 +9,5 @@ inherit pypi
RDEPENDS_${PN} += " \
${PYTHON_PN}-pprint \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-xml \
"
diff --git a/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
index 5e089a90f2..ca5a79a788 100644
--- a/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
@@ -1,2 +1,6 @@
require python-netaddr.inc
inherit setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-textutils \
+"
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
index 1067d156ac..0e99917c21 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
@@ -4,5 +4,4 @@ require python-prompt-toolkit.inc
RDEPENDS_${PN} += " \
${PYTHON_PN}-datetime \
${PYTHON_PN}-shell \
- ${PYTHON_PN}-textutils \
"