aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2018-08-06 17:45:07 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-08 12:04:14 -0700
commitaee991551f113fa8b65b67155d4d36e6ccd2e3f5 (patch)
tree9e1ace2e44d8f4fc523844eebf5aaf4ce3fb3f09 /meta-python/recipes-devtools
parentb87b595ab12c19a32c4ae0b71288afcf72cb5684 (diff)
downloadmeta-openembedded-aee991551f113fa8b65b67155d4d36e6ccd2e3f5.tar.gz
python-future: make recipe available as python3 version
Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-future.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-future_0.16.0.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-future_0.16.0.bb2
3 files changed, 17 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-future.inc b/meta-python/recipes-devtools/python/python-future.inc
new file mode 100644
index 0000000000..2247561809
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-future.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Clean single-source support for Python 3 and 2"
+HOMEPAGE = "https://python-future.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f457538b297bd0ef86564b8ac216ad7"
+
+SRC_URI[md5sum] = "3e8e88a2bda48d54b1da7634d04760d7"
+SRC_URI[sha256sum] = "e39ced1ab767b5936646cedba8bcce582398233d6a627067d4c6a454c90cfedb"
+
+PYPI_PACKAGE_HASH = "99abde815842bc6e97d5a7806ad51236630da14ca2f3b1fce94c0bb94d3d"
+
+inherit pypi
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-future_0.16.0.bb b/meta-python/recipes-devtools/python/python-future_0.16.0.bb
index 46f7fe50f6..d95e1ba774 100644
--- a/meta-python/recipes-devtools/python/python-future_0.16.0.bb
+++ b/meta-python/recipes-devtools/python/python-future_0.16.0.bb
@@ -1,13 +1,2 @@
-DESCRIPTION = "Clean single-source support for Python 3 and 2"
-HOMEPAGE = "https://python-future.org"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f457538b297bd0ef86564b8ac216ad7"
-
-SRC_URI[md5sum] = "3e8e88a2bda48d54b1da7634d04760d7"
-SRC_URI[sha256sum] = "e39ced1ab767b5936646cedba8bcce582398233d6a627067d4c6a454c90cfedb"
-
-PYPI_PACKAGE_HASH = "99abde815842bc6e97d5a7806ad51236630da14ca2f3b1fce94c0bb94d3d"
-
-inherit pypi setuptools
-
-BBCLASSEXTEND = "native"
+inherit setuptools
+require python-future.inc
diff --git a/meta-python/recipes-devtools/python/python3-future_0.16.0.bb b/meta-python/recipes-devtools/python/python3-future_0.16.0.bb
new file mode 100644
index 0000000000..f059186bf8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-future_0.16.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-future.inc