aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-07 17:01:03 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-09 07:37:04 -0800
commit48618e73b856cedb5272c80ace668a44e899289e (patch)
treec9f065be201f1ed8cde488163b4598db8a2511a9 /meta-python/recipes-extended
parent5eba739c7597f42338f839e4ca1cbdf34ee2ada3 (diff)
downloadmeta-openembedded-48618e73b856cedb5272c80ace668a44e899289e.tar.gz
python3-meh: use setuptools_legacy
This setup.py installs data_files with absolute paths, which isn't supported by bdist_wheel. Use setuptools_legacy as the legacy install task needs to be used. Also update patch status on the setuptools port. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch3
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb12
2 files changed, 3 insertions, 12 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
index b616b3fad3..2eb6be5a18 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
+++ b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
@@ -9,8 +9,7 @@ In Python 3.10 'distutils' is deprecated with removal slated for Python
This also allows for a 'wheel' binary archive format to be built with
'setup.py bdist_wheel'.
-Upstream-Status: Submitted
-[https://github.com/rhinstaller/python-meh/pull/37]
+Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322]
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
index 9f72b72623..1d9af438da 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "https://github.com/rhinstaller/python-meh"
LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-inherit setuptools3
+inherit setuptools3_legacy
S = "${WORKDIR}/git"
@@ -14,12 +14,4 @@ SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhe
"
SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed"
-PIP_INSTALL_PACKAGE = "python_meh"
-
-do_install:append () {
- install -d ${D}/${datadir}/python-meh
- mv ${D}${PYTHON_SITEPACKAGES_DIR}${datadir}/python-meh/* ${D}/${datadir}/python-meh/
-}
-
-FILES:${PN} += "${datadir}/*"
-
+FILES:${PN} += "${datadir}/python-meh"