aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-08-03 14:13:38 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:37:42 -0700
commit88efe3c0ea78196b53d0c6606887b9cf72ca632c (patch)
treeb10f6956d688a508a550b67a165e7d48e2b4718f /meta-python/recipes-extended
parentbf1057e64076c9e6909cf694cfae2b8a1991d341 (diff)
downloadmeta-openembedded-88efe3c0ea78196b53d0c6606887b9cf72ca632c.tar.gz
python3-blivet: 3.1.4 -> 3.4.0
Upgrade python3-blivet from 3.1.4 to 3.4.0. * it imports selinux conditionally, so remove 0001-comment-out-selinux.patch * rebase 0008-use-oe-variable-to-replace-hardcoded-dir.patch and 0010-invoking-mkfs-with-infinite-timeout.patch Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch70
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch8
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch10
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb)5
4 files changed, 15 insertions, 78 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch
deleted file mode 100644
index 90fa387b01..0000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From fc8e93530ba017ecfe111e53d3cbdc3a5b3ac286 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Fri, 23 Nov 2018 16:58:38 +0800
-Subject: [PATCH 01/11] comment out selinux
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- blivet/flags.py | 5 +++--
- blivet/util.py | 6 +++++-
- 2 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/blivet/flags.py b/blivet/flags.py
-index 4e26d82..94324ff 100644
---- a/blivet/flags.py
-+++ b/blivet/flags.py
-@@ -20,7 +20,7 @@
- #
-
- import shlex
--import selinux
-+#import selinux
-
-
- class Flags(object):
-@@ -47,7 +47,8 @@ class Flags(object):
- #
- # enable/disable functionality
- #
-- self.selinux = selinux.is_selinux_enabled()
-+ #self.selinux = selinux.is_selinux_enabled()
-+ self.selinux = False
- self.multipath = True
- self.dmraid = True
- self.ibft = True
-diff --git a/blivet/util.py b/blivet/util.py
-index 9daf151..4eac8b9 100644
---- a/blivet/util.py
-+++ b/blivet/util.py
-@@ -3,7 +3,7 @@ import functools
- import glob
- import itertools
- import os
--import selinux
-+#import selinux
- import subprocess
- import re
- import sys
-@@ -444,6 +444,8 @@ def get_cow_sysfs_path(dev_path, dev_sysfsPath):
- def match_path_context(path):
- """ Return the default SELinux context for the given path. """
- context = None
-+ return context
-+
- try:
- context = selinux.matchpathcon(os.path.normpath(path), 0)[1]
- except OSError as e:
-@@ -468,6 +470,8 @@ def set_file_context(path, context, root=None):
-
- True if successful, False if not.
- """
-+ return False
-+
- if root is None:
- root = '/'
-
---
-2.7.4
-
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
index ade1862d78..1e8bcac47e 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
@@ -6,6 +6,10 @@ Subject: [PATCH 08/11] use oe variable to replace hardcoded dir
Upstream-Status: Pending
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+Rebase for python3-blivet 3.4.0.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
setup.py | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
@@ -19,11 +23,11 @@ index b745a79..b5b4258 100644
data_files = [
- ('/etc/dbus-1/system.d', ['dbus/blivet.conf']),
-- ('/usr/share/dbus-1/system-services', ['dbus/com.redhat.Blivet1.service']),
+- ('/usr/share/dbus-1/system-services', ['dbus/com.redhat.Blivet0.service']),
- ('/usr/libexec', ['dbus/blivetd']),
- ('/usr/lib/systemd/system', ['dbus/blivet.service'])
+ (os.environ.get('sysconfdir')+'/dbus-1/system.d', ['dbus/blivet.conf']),
-+ (os.environ.get('datadir')+'/dbus-1/system-services', ['dbus/com.redhat.Blivet1.service']),
++ (os.environ.get('datadir')+'/dbus-1/system-services', ['dbus/com.redhat.Blivet0.service']),
+ (os.environ.get('libexecdir'), ['dbus/blivetd']),
+ (os.environ.get('systemd_system_unitdir'), ['dbus/blivet.service'])
]
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
index f128490458..c441acd173 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
@@ -9,17 +9,21 @@ lots of disks, or with slow disks.
Upstream-Status: Pending
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+Rebase for python3-blivet 3.4.0.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
blivet/tasks/fsmkfs.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/blivet/tasks/fsmkfs.py b/blivet/tasks/fsmkfs.py
-index ad166aa..7bf5075 100644
+index e4a6aaa8..9730f7e5 100644
--- a/blivet/tasks/fsmkfs.py
+++ b/blivet/tasks/fsmkfs.py
-@@ -170,7 +170,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask):
+@@ -203,7 +203,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask):
options = options or []
- cmd = self._mkfs_command(options, label, set_uuid)
+ cmd = self._mkfs_command(options, label, set_uuid, nodiscard)
try:
- ret = util.run_program(cmd)
+ ret = util.run_program(cmd, timeout=-1)
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
index 204793759d..d3373f4ae2 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
@@ -8,9 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
S = "${WORKDIR}/git"
B = "${S}"
-SRCREV = "9b5ad2d5b5df159963e1c6c24523e1dfe1f71435"
-SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \
- file://0001-comment-out-selinux.patch \
+SRCREV = "f7d9027e4fdad11187980e73726cd75a2dc962c2"
+SRC_URI = "git://github.com/storaged-project/blivet.git;branch=3.4-release \
file://0002-run_program-support-timeout.patch \
file://0003-support-infinit-timeout.patch \
file://0004-fix-new.roots-object-is-not-iterable.patch \