aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-05-09 12:42:23 +0800
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:41:35 -0700
commit07f1e0be8d428d0a643dad67adf81dd76ce53579 (patch)
treec4136a25024ef18520a1f30a0de5068dd5bcac67 /meta-python
parent47b63311bdeb494a7db3421def9c8e007e826602 (diff)
downloadmeta-openembedded-07f1e0be8d428d0a643dad67adf81dd76ce53579.tar.gz
python3-zipp: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import zipp ModuleNotFoundError: No module named 'zipfile' ModuleNotFoundError: No module named 'random' python3-math Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 16b524d00a1f0684093b278a45f98fa736dda1e2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
index 1019081f38..40db3c071a 100644
--- a/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
@@ -10,6 +10,8 @@ DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
inherit pypi setuptools3
-RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
+RDEPENDS_${PN} += "${PYTHON_PN}-compression \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-more-itertools"
BBCLASSEXTEND = "native nativesdk"