aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-05-08 11:23:58 +0800
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:38:03 -0700
commit5d53a615098ec46c1180ea458b5ba99598db71a7 (patch)
tree1196d0d981029daa047f53374adeb4758daebec1 /meta-python
parent4cee153f598f4bc5fd2e1982a99b8c8937131e4e (diff)
downloadmeta-openembedded-5d53a615098ec46c1180ea458b5ba99598db71a7.tar.gz
python3-pydbus: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import pydbus [snip] ModuleNotFoundError: No module named 'socket' ModuleNotFoundError: No module named 'logging' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 55190da2eba946319453531021089186bd2dd551) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
index 931bc6f7cb..807e7b2de5 100644
--- a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
@@ -14,4 +14,6 @@ inherit pypi setuptools3
S = "${WORKDIR}/pydbus-${PV}"
-RDEPENDS_${PN} = "${PYTHON_PN}-pygobject"
+RDEPENDS_${PN} = "${PYTHON_PN}-pygobject \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging"