aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 14:39:28 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commit72eaf6a0ea7a85749d90f0f051354ebe8574de42 (patch)
tree574c7a51c7cfda4db7c701a79d7ce47a98a4a00c /meta-python
parentd8eb504d76fdbf21a1b2071c79537c1337344056 (diff)
downloadmeta-openembedded-72eaf6a0ea7a85749d90f0f051354ebe8574de42.tar.gz
python-pyelftools: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyelftools.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb16
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyelftools.inc b/meta-python/recipes-devtools/python/python-pyelftools.inc
deleted file mode 100644
index 7d4f763ffd..0000000000
--- a/meta-python/recipes-devtools/python/python-pyelftools.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
-HOMEPAGE = "https://github.com/eliben/pyelftools"
-SECTION = "devel/python"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
-
-SRC_URI[md5sum] = "c5629b9a5d19c82107a946cce52eeec2"
-SRC_URI[sha256sum] = "89c6da6f56280c37a5ff33468591ba9a124e17d71fe42de971818cbff46c1b24"
-
-PYPI_PACKAGE = "pyelftools"
-
-inherit pypi
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb b/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
index 56eb8c4cd6..03d96db3c2 100644
--- a/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
+++ b/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
@@ -1,2 +1,14 @@
-inherit setuptools3
-require python-pyelftools.inc
+DESCRIPTION = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
+HOMEPAGE = "https://github.com/eliben/pyelftools"
+SECTION = "devel/python"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
+
+SRC_URI[md5sum] = "c5629b9a5d19c82107a946cce52eeec2"
+SRC_URI[sha256sum] = "89c6da6f56280c37a5ff33468591ba9a124e17d71fe42de971818cbff46c1b24"
+
+PYPI_PACKAGE = "pyelftools"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"