aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-05-07 09:16:37 -0700
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:34:55 -0700
commit824b48dfdca6b1a602972691fb253f135f6e7657 (patch)
treed07ef8559326b9e690151b17474388ae6891b6d0 /meta-python
parent4ccf941dd26e15fa97524c5f13f9a00963e16985 (diff)
downloadmeta-openembedded-824b48dfdca6b1a602972691fb253f135f6e7657.tar.gz
python3-py: add python3-netclient to RDEPENDS
python3-py requires the uuid.py module, which is contained in python3-netclient. Without it: root@qemux86-64:~# python3 >>> import py._path.local Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.8/site-packages/py/_path/local.py", line 7, in <module> import sys, os, atexit, io, uuid ModuleNotFoundError: No module named 'uuid' Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 71bb82f31283398a6bc6e614444b8b73f2763591) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-py_1.8.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-py_1.8.1.bb b/meta-python/recipes-devtools/python/python3-py_1.8.1.bb
index 73aaf9e46a..ff66aeaa2b 100644
--- a/meta-python/recipes-devtools/python/python3-py_1.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-py_1.8.1.bb
@@ -11,3 +11,5 @@ DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
inherit pypi setuptools3
BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-netclient"